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Abstract
This senior project was to design and implement the graphical user interface for a menu bar editor to be used in Gene Fishers prototyping tool, ProtoJ.  The interface itself is simple, containing an area to enter text with visible tab stops, and standard Ok and Cancel buttons. The behavior of the editor itself is fairly complex. For example, it responds to “tab” and “enter” keypresses in a custom manner to create a better feel for a menu tree hierarchy editor. Resizing the dialog window also proved to be more complicated than originally anticipated. The menu bar editor was implemented in Java (JDK 1.4.2)
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1. Introduction

This report contains an in-depth examination of the Menu Bar Editor dialog for the ProtoJ project. 

1.1. Description of the Problem

ProtoJ is a prototyping tool developed by students for Dr. Gene Fisher to be used in software engineering courses (primarily CSC 205 and 206) at Cal Poly. When completed, it will be a powerful, flexible, and easy to use tool for creating prototypes for software projects. 

ProtoJ has many useful features including its support for customized menu bars and contains a Menu Bar Editor (MBE) which allows users to easily create menu bars for use in their prototypes. The problem addressed in this report is how to design and implement the MBE so that it would be efficient, flexible, powerful, intuitive, and easy to use while remaining visually simple and pleasing to the eye.

Concerns about the MBE included how to visually represent the menu structure in the editor. A menu system is usually represented conceptually as a tree-like hierarchy with different levels of elements. However, the typical view of a tree did not seem like a good way to visualize a menu system for the editor. The goal was to determine the best way to visually represent the menu structure so that it made sense and was easy to use at the same time.

Another concern about the MBE arose once the visual representation was decided upon. Namely, how should it be implemented? The goal was then to implement the MBE so that it fit with the visual representation but still be flexible and efficient.

The visual representation of the menu structure came out fairly cleanly. However, the implementation proved to be more difficult than originally expected and ended up involving quite a bit of creativity.

1.2. Overview of the Solution

This section contains a brief overview of the design and implementation of the MBE. Details can be found in sections 2 – 4 of this report and also in the Requirements Specification for the ProtoJ project, at 
http://waldorf.csc.calpoly.edu/~gfisher/projects/protoj/requirements.

1.2.1 Visual Representation

We decided that the best way to represent the menu system visually was with a textual hierarchy. The structure of the menu is indicated by the layout of the text. Elements of a menu are indented one level underneath that menu. Submenus are created similarly. For example, consider the following textual representation of a menu:

File


New


Open


Save


Close

Edit


Cut


Copy


Paste

Here, the root menus are File and Edit. The File menu contains the elements New, Open, Save, and Close, and the Edit menu contains the elements Cut, Copy, and Paste.

1.2.2 Implementation

ProtoJ itself is implemented in Java and so is the MBE. The implementation process resulted in a MBE dialog window. The MBE dialog is simple in appearance yet complex in behavior. The dialog contains a text editor for quick and easy hierarchical editing of a menu tree. Each line in the editor corresponds to an element in the resulting menu and the indentation level of each line determines the hierarchy level of each element.

The text editor’s behavior is customized to flow naturally with the task of creating a hierarchy. In particular, an “enter” keystroke not only moves the cursor to the next line but also indents automatically to the previous level. Furthermore, the number and location of indentations (“tab” keystrokes) are limited per line to enforce the concept of a hierarchy.

Vertical lines overlay the text editor for a visual representation of indentation levels. The number and size of the lines change dynamically as the text editor is resized. These visual guides along with the customized behavior of the text editor result in a dialog that is very intuitive and easy to use.

1.3. Outline of the Report

The remainder of this report discusses the details of the MBE dialog window. In particular, it includes an example of the dialog in action (Section 2), a discussion of the architectural design (Section 3), details of the implementation (Section 4), comparisons between existing works related to the project (Section 5), and future work concerning the project (Section 6).

2. Scenario of Dialog Use

This section contains an example interaction between a user and the MBE dialog. The scenario shows how the MBE dialog is used to create a functional menu bar for a ProtoJ project.

2.1 Invoking the Dialog

Assume the user has successfully started the ProtoJ application. The initial state of ProtoJ is seen in Figure 1. The user invokes the MBE dialog by clicking the Menu Bar button in the upper right corner of the Components window. 
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	Figure 1.  The initial state of the ProtoJ application.


After the user clicks the Menu Bar button, the MBE dialog appears in its initial state as shown in Figure 2. 
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	Figure 2. The initial state of the MBE dialog.



2.2 Using the Dialog

The dialog is now ready for the user to begin entering menu information. The user wants to create a “File” menu. To do so, they begin typing the word “File.” The user then presses the “enter” key to continue on and enter another element of the menu.

The user wants to create elements within the “File” menu that was just entered. To do this, the user presses the “tab” key and then types the word “New.” Now the “File” menu contains an element called “New.”

The user also wants the “File” menu to contain an element called “Open.” The user presses the “enter” key again to enter another element. This time however, the cursor is automatically placed directly underneath the “New” element (the user did not have to press the “tab” key). The user types in the word “Open” to add that element to the “File” menu. The results thus far are shown in Figure 3.
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	Figure 3. The MBE dialog after a few lines of input.





The user continues in this manner until they have entered all the desired menus, submenus, and elements of the menu bar. An example of a filled in dialog can be seen in Figure 4.
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	Figure 4. The MBE dialog filled in.


The filled in dialog contains “File,” “Edit,” and “View” menus. The “View” menu contains the items “Zoom In” and “Zoom Out.” The “View” menu also contains a submenu called “Toolbars.” The “Toolbars” submenu contains the items “Standard” and “Drawing.”

2.3 Resizing the Dialog

Normally, the ability to resize a dialog window would not be worth noting. For the MBE however, allowing the user to resize the window was tricky to implement and so I would like to demonstrate the dialog’s behavior. (Implementation details can be found in section 4 of this report.)

Assume the user has entered the menu structure as seen in section 2.2 into the MBE. Also assume that the user would like to reduce the size of the MBE window in order to re-arrange open windows. To do this, the user may click on the bottom right corner of the window and drag inward (just like resizing any other window). The resized window will contain any appropriate scrollbars that are required as well as dynamically redrawn vertical guides. The result can be seen in Figure 5.
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	Figure 5. The MBE dialog window resized.



2.4 The Finished Menu

Once the user has finished entering all the elements of the menu, he or she clicks the OK button to accept the changes and create the menu. Alternatively, if the user does not want to accept the changes, he or she clicks the Cancel button and the window will close and any existing menu will remain unchanged.

When the user clicks the OK button, a new menu bar is created and attached to the main ProtoJ document window. If a menu bar already existed, it is modified to reflect the changes. The final result can be seen in Figure 6.
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	Figure 6. The resulting created menu bar.


This concludes user scenario examples of the MBE dialog.

3. Architectural Design

The architectural design for ProtoJ’s MenuBarEditor is fairly straightforward. The two main classes involved are the MenuBarEditor class itself and a LinePanel class. The MenuBarEditor class extends JFrame and the LinePanel class extends JPanel. Figures 7 and 8 illustrate the structure of each class respectively.
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	Figure 7. Class Diagram for the MenuBarEditor class.
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	Figure 8. Class Diagram for the LinePanel class.


Javadoc details of these classes are available in the project repository at http://waldorf.csc.calpoly.edu/~gfisher/projects/protoj/design.

4. Implementation Details

When I began working on this project, there was already an existing implementation of the MenuBarEditor. However, it did not reflect the look and feel described in ProtoJ’s requirements documentation. My task was to convert the existing MBE so that it more accurately reflected what was documented in the requirements specification.

4.1 Look of the MBE

The first task was to get the MBE to look correctly. The existing implementation required the user to enter menu bar information in a large table which was not what was originally specified. Instead, we wanted the flexibility of a text area with the added visual aid of vertical guides.

The text area naturally translated into the Java class of JTextArea. The main obstacle was deciding how to implement the vertical guides. We decided to try and implement an extension of JPanel called LinePanel. The LinePanel class would have a custom paint method that would create the vertical lines. The panel itself would be transparent (using setOpaque(false)) so that the lines would be visible but the panel itself would not. This worked out well, the only problem was getting the LinePanel to overlay the JTextArea.

We decided that the best way to overlay the JTextArea with the LinePanel was to put both components into a JLayeredPane. This would allow us to set the LinePanel to a layer which was above that of the text area creating the desired effect.

4.2 Feel of the MBE

Once the look of the dialog was correct, the desired behavior needed to be implemented the way we wanted. This proved to be a non-trivial task and I ran across several problems during development.

4.2.1 Resizing the Dialog
The fact that a JLayeredPane is not associated with a LayoutManager created a problem. Most LayoutManagers will automatically resize components when their parent container gets resized. Since the JLayeredPane doesn’t have a LayoutManager, this would have to be done manually. I experimented with many ideas but with few results. Eventually I stumbled upon the Component method addHierarchyBoundsListener. A HierarchyBoundsListener will fire an event when a parent container is resized. Knowing when the dialog was resized allowed us to manually resize both the text area and the LinePanel whenever necessary.

Another resizing problem was when the scrollbars for the JTextArea (which was placed inside of a JScrollPane) were set to be visible as needed. The scrollbars appeared inside the text area, not outside. This meant that the vertical lines that were once correctly drawn over the extent of the text area now overlaid the scrollbars as well. To put it simply, this was tacky and was not the desired behavior. Finding a way around this problem proved to be tricky. To solve it I ended up adding a ChangeListener to the JScrollPane’s viewport to know when its dimensions changed and used the viewport’s ExtentSize to determine the new area that needed to be filled in with the lines. Doing so simplified the LinePanel’s paint method (no more offsets) and also made it more flexible (simply autoSize the LinePanel giving it the desired Dimension and it will repaint itself appropriately).

4.2.2 Text Area Behavior

Once all the dialog specific feel issues were dealt with, focus turned to the text area. We wanted to customize the behavior of the text area so that it flowed more naturally with the task at hand. This meant changing the way that the “enter” and “tab” keystrokes were handled. To accomplish this, a new class was created called MenuBarEditorTextArea which extends JTextArea. This new class overrides the JComponent method processKeyEvent which allows for custom behavior when certain keys are pressed. This allowed for the customization we were looking for (specifics on the desired behavior can be found in section 1.2.2 of this report).

5. Related Work

Being able to create menu bars is not a new concept. There are several other applications that allow for the same functionality. For example, Microsoft Visual Basic .NET has a nice interface for creating menus. Instead of a dialog window where you enter information about the menu you want, you actually see the menu be built from scratch and simply type in each element item. Every time a new item is entered, there is the option to enter the next. It has full support for submenus as well. Figure 9 shows an example of a Visual Basic .NET menu being built.
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	Figure 9. Microsoft Visual Basic .NET menu editing.


The NetBeans IDE also has the ability to create customized menus. However, it is a lot more complex and quite primitive when compared to both ProtoJ’s MBE and Visual Basic’s methods. NetBeans makes extensive use of pop-up menus and unless the user is familiar with the IDE and where everything is located, it will probably take a while to find what he or she is looking for. Figure 10 shows an example of a NetBeans IDE menu structure being edited.
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	Figure 10. NetBeans IDE menu editing.


While the MBE in ProtoJ provides similar functionality to the editors in both Visual Basic .NET and NetBeans, it also has its differences. It is Java based when compared to Visual Basic which makes it much more portable, and it is also much less programmer oriented when compared to NetBeans.
6. Conclusions and Future Work

The end result of ProtoJ’s MenuBarEditor is easy to use, pleasing to the eye, and also quite flexible. We encountered several problems along the way but were able to find relatively simple solutions to all of them. I have learned a great deal about what it is like to contribute to a large-scale software project. My only regret is not having more time to work on it.

ProtoJ itself it not quite finished yet but is scheduled for a beta release in time for use in Fall 2004’s CSC 205/206 classes. It has been an ongoing senior project passed on from person to person and has even been worked on in teams. Once completed, ProtoJ will be a very useful tool for prototyping software projects and it has certainly been an enjoyable, yet challenging senior project.
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