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Overview

In today’s world of global commerce it is increasingly important to get a product out to as many people as possible to make it competitive.  Limiting a product to just one language can severely limit the potential market for it.  This is true even in the computer industry.  While lot’s of people who work with computers are competent with English, users are much more likely to be comfortable with a program that is in their own language.  

Java helps fix this problem by introducing the idea of internationalization.  Internationalization uses resource bundles as an easy way to switch from one language to the next.  A program detects which location the user has set in their system settings and then loads the appropriate resource bundle that contains the proper strings and other types of data appropriate for that region.  Unfortunately, creating and editing these huge resource bundles can be a huge problem, especially to a translator who has minimal programming skills.  That’s where this program comes in.

QuartzWare RBEdit, the Java Resource Bundle Editor, makes creating and editing resource bundles simple by providing a simple user interface and creating the resource bundles for the user.  It can manage all of the resource bundles together in one project so that a translator never has to actually look at a resource bundle.  This means less training time required for training translators, and also makes the job of anyone, including the programmer, who has to work with Java resource bundles a lot easier.

What is a Resource Bundle?

A Resource Bundle is a collection of strings and other data that is to be used in a given program.  The resource bundle contains keys that the program uses to look up these strings and other data to display the program correctly to the end user.  Resource bundles can be divided into two types:

1. Root – This is the file that has every single key and is the default if a child does not have a
particular key when the program makes an inquiry.  Every key has a particular data type (such as a string or a picture) associated with it, and of course some data.  There is only one Root per project.

2. Child – A file that contains different text and formatting (such as dates and time) in a different language.  Also, other data, such as pictures, can be different from the root.  The child can be further divided into three types:

· Language – This category is defined in the ISO-639 standard and contains all the translated strings and data.  The parent of a Language Resource Bundle is always the root.

· Country – This category is defined in the ISO-3166 standard and contains any deviations that a language might have from country to country.  Also, formatting, such as dates and time, and pictures, such as that of the countries national flag may be different from country to country.  The parent of a Country Resource Bundle is always a Language Resource Bundle.

· Variant – If there are variations of a language inside of a country, these variations will be found in this file.  The parent of a Variant Resource Bundle is always a Country Resource Bundle.

The root of a resource bundle will usually be contained in a file named something similar to “ResourceBundle.class” (depending on the file type that is chosen).  In this example, the base name now becomes “ResourceBundle”.  All of the children have the same base name with their appropriate extensions.  For instance, English will be defined in a Resource Bundle file named “ResourceBundle_en.class” and it’s US variation stored in “ResourceBundle_en_US.class”.  See the ISO-639 and the ISO-3166 standards for the naming conventions.  The children Resource Bundles only contain the data that is different from their parents’ data.  Of course QuartzWare RBEdit will take care of this for you behind the scenes.  Once the root has been translated into the correct language, all a program has to do is figure out which country it’s in and make a call to the Resource Bundle.

Managing Files

In this section, we will talk about what files are involved in a resource bundle project, and how QuartzWare RBEdit manages these files.

A Project vs. a Loose File

The idea behind resource bundles is that there is one file for every language and variation on a language.  A project is a collection of all the files that make up the resource bundles for one particular program.  A project file is created which contains a list of all of the other files in the project, as well as any preferences for that project.  This way, when you load a project, the program automatically loads all of the other resource bundle files in.  A project file has the same name as the root of the Resource Bundle, but it has an extension of ‘RBP’.

Sometimes an entire project is not available and you may wish to work with an individual Resource Bundle.  This is what is known as a loose file, since it isn’t attached with the project currently loaded.  While loose files can be edited in QuartzWare RBEdit, severe restrictions on editing will be in place.  For instance, you will not be able to add a new key or delete a key from a loose file unless it is itself a root.  This is so any child Resource Bundles will not become out of sync with their parents.

Starting a New Project

Starting from Scratch

To start a new project from scratch:

· Select ‘New Project…’ from the ‘File’ menu

· Click on ‘Create New Root’

· Name your Project File whatever you wish.

· Click ‘Save’ to create the Project File and the Root

[Picture of New Project dialogue box]

[Picture of Create New Root dialogue box]

The name you give the Project File will be used as the base name for all of the Resource Bundle Files including the root.

Starting from an existing root

To start a new project based off of existing files:

· Select ‘New Project…’ from the ‘File’ menu

· Click on ‘Import Root’

· Find the Root you wish to import and click on ‘Import’

· A Save Project dialogue will appear.  Name the project what you wish to and click ‘Save’

· Load any previously created project files that go with that Root (See ‘Loading an existing Child into the Project’ on page 7)

[Picture of Import Root dialogue]

If there is a Project already loaded, then a dialogue box will pop up asking if you wish to save.  The base name of the root that you import will be used as the default name in the Save Project dialogue.  Whatever name you choose in the Save project dialogue will be used as the base name for the Project File and all of the children that you load or create.

Loading Files 

Loading an existing Project

To load an existing Project:

[Picture of Open Project Dialogue]

· Select ‘Open Project’ from the’ File’ menu

· Find the Project File for the Project that you wish to load. (Remember that Project files have the extension RBP)

· Click Open to load it into the Resource Editor

If there is a Project already loaded, then a dialogue box will pop up asking you if you wish to save.  The program will automatically load all the files listed in the Project that you load.  If any are missing, a warning message will pop up, asking if you still wish to continue.  If the root is missing then [? What happens here?]  

Loading a Loose File

See ‘A Project vs. a Loose File’ on page 3 for a description of a Loose File.

To load a Loose File:

[Picture of Open dialogue box]

· Select ‘Open’ from the ‘File’ menu

· Find the Loose File that you wish to load

· Click Open to load it

· If a project is already loaded, the Resource Editor will ask if you wish to add this to the current project.  Click no.

Remember that a Loose File (unless it is a root) has many restrictions imposed on it to help prevent it from getting out of sync with its Root.

Saving Files

Saving the project

To save your project:

· Make sure that a file in the Project (not a loose file) is in focus

· Select ‘Save Project’ from the ‘File’ menu

If a Loose File has focus, Save Project will be grayed out.  To prevent the children from going out of sync with the root, you are not allowed to individually save the children of a loaded project

Saving the project as a different name

To save your project using a different base name:

[Picture of Save Project As dialogue box]

· Select ‘Save Project As…’ from the ‘File’ menu

· Type in a new name for the Project

· Click Save

The Project File and all of the Resource Bundle Files will be saved using the new name for the Project as the base name.  The previously saved version of all of the Resource Bundles, including the Project File, will remain unchanged.  If this process will cause any files to be overwritten, a warning message will appear first.

Saving a loose file

See ‘A Project vs. a Loose File’ on page 3 for a description of a Loose File.

To save a Loose File:

· Make sure that the Loose File you wish to save is in focus

· Select ‘Save’ from the ‘File’ menu

If a file in the currently loaded Project has focus, then Save will be grayed out.

Working with the files of a Project

Adding a new Child into the Project

To create a new Child for the Project:

· Select ‘New Child’ from the ‘Project menu

· Select the language that the child needs to be and click ‘OK’

[Picture of Create New Child dialogue box]

The new child will automatically use the base name of the Project File with the appropriate language extensions the next time the Project is saved.  If a child has a key that the root does not then a dialogue box will pop up with the following options:

· Add Key to Root

· Delete Key from child

· Cancel Loading

Loading an existing Child into the Project

To add an existing Child to the Project:

· Select ‘Add Child’ from the ‘Project’ menu

· Select the language that the child is in and click ‘OK’

[Picture of the Add Child dialogue box]

The new child will automatically use the base name of the Project File with the appropriate language extensions the next time the Project is saved.  If a child has a key that the root does not then a dialogue box will pop up with the following options:

· Add Key to Root

· Delete Key from child

· Cancel Loading

Removing a child from the Project

To remove a Child from the Project:

[Picture of the Project Tree]

· Select the child in the Project Window that needs to be removed from the Project

· Select ‘Remove Child’ from the ‘Project’ menu

· A warning message will pop up.  Click Yes

Warning!  Removing a child will also remove all of its children.  For example, removing “ResourceBundle_en” will also remove “ResourceBundle_en_US”.  The files are not deleted, but they are removed from the project.  Any changes made to them since the last time the project was saved will be lost.  You may not remove the Root.

Closing Files

Closing a Project

To close a Project:

· Make sure that any file in a project has focus

· Select ‘Close’ from the ‘File’ menu

A message will pop up asking if you really wish to save the Project.  Click ‘Yes’ to save it.

Closing a Loose File

See ‘A Project vs. a Loose File’ on page 5 for a description of a Loose File.

To close a Loose File:

· Make sure that the Loose file you wish to close has focus

· Select ‘Close’ from the ‘File’ menu

A message will pop up asking if you wish to save the Loose File.

Using the Application Window

The Toolbar

The Toolbar contains shortcuts to various functions that our program supports.  The functions supported are illustrated in the following picture:

[Picture of toolbar with annotations]

The Project Window

The Project Window contains a listing of the files in your project in a tree format.  Each icon in the Project Window represents one Resource Bundle file.  Children are stored on a branch below their parents, and of course the Root is at the top.  Double click on a file to display it in an Editor Window.  Right click in the Project Window to bring up a Pop-Up menu.  To collapse a branch, single click on the ‘-‘ next to it.  To expand a collapsed branch, single click on the ‘+’ sign next to it.

[Picture of Pop-Up menu with annotations]

[Need to specify features of the Pop-Up menu]

You may not close the Project Window, but you may minimize it.  The Project Window is always accessible from the Easy Tabs bar.

The Editor Windows

The Editor Windows completely encompasses the resource bundles.  They allow for both display and modification of resource bundles.  The Editor Window has four columns:  Key, Value, Parent Value, and Comments.  One row in the editor window is called an Entry.  Each entry, therefore, has one Key, one Value, one Parent Value, and one block of comments.

Undoing and Redoing

QuartzWare RBEdit supports one undo and redo function per editor window.  Selecting Undo from the ‘Edit’ menu will change the last value modified to its previous value.  Selecting Redo from the ‘Edit’ menu will change the value back (as if you had never pressed ‘Undo’ in the first place).

Manipulating text

The cut, copy, and paste features are available when editing the value or comment of an entry.  

Working with Entries

In order to add a new key, either:

· Select ‘New Key’ from the ‘Edit’ menu

· Right click on an Editor Window to bring up a Pop-Up menu, then select ‘New Key’

· Click the ‘New Key’ Icon on the Toolbar.  [Show picture of New Key Icon]

If working with a Loose File (See A Project vs. a Loose File on page 5) then you will not be able to add a new key.

In order to delete a key, select an entry in an editor window, then either:

· Select ‘Delete Key’ from the ‘Edit’ menu

· Right click on the selected entry to bring up a Pop-Up menu, then select ‘Delete Key’

· Click the ‘Delete Key’ Icon on the Toolbar.  [Show picture of Delete Key Icon]

When you try to delete a key, a dialogue box will pop up asking if you are sure.  If working with a Loose File (See A Project vs. a Loose File on page 5) then you will not be able to delete a key.

In order to modify the name of a Key:

· Select ‘Rename Key’ from the ‘Edit’ menu

· Right click on the selected entry in an Editor Window to bring up a Pop-Up menu, then select ‘Rename Key’

Renaming a Key should be done with great caution.  This feature is included to allow the correction of typos in the name of a Key.  Any time the Key is changed, it will be changed in ALL files, including the root and every child in the project.  A warning message will pop up asking if you are sure you wish to change the Key.

In order to modify a value or comment, select an entry in an editor window, then either:

· Select ‘Edit Value’ or ‘Edit Comments’ from the ‘Edit’ menu

· Double click on the Value or Comments field in the Editor Window

· Right click on the selected entry to bring up a Pop-Up menu, then select  ‘Edit Value’ or ‘Edit Comments’

· Click the  ‘Edit Value’ or ‘Edit Comments’ button on the toolbar  [Show a picture of the Edit Value and Edit Comments icons]

[Show some pictures of the various type of dialogues that will come up for the different types of keys and explain all of them]

If the value is not a string, then there will be a button in the ‘Value’ column that says ‘Show …’.  Clicking on this button will bring up a dialog that both displays the value and allows modification.

When the value of a child is changed, the entire row in the Editor Window will become a light gray to indicate that it is different from it’s parent value.  If a child returns to it’s parent value again than the row will turn white again.  The color that the row turns can be selected from the Preferences dialogue.  See page 11.

Searching

Selecting ‘Find’ from the ‘Edit’ menu will bring up a Search Dialog.  The Search Dialog has a number of options.  ‘Search All Files’ will search through all files in the current project.  If this option is turned off, only the currently active window will be searched.  De-select ‘Search Keys’, ‘Search Values’, or ‘Search Comments’ if you wish to narrow the scope of the search.

The Easy Tabs

The Easy Tabs work similar to the Microsoft Windows’ Taskbar, and they are a simple way to keep track of your work.  It contains a Tab for each Editor Window that is open (including the Project Window).  If a tab is selected, the associated window will become the active window.  If the associated window is minimized, it will restore it, as well as place it on top of any windows that might have been covering it up.

Miscellaneous Features

Testing

Testing allows the user to preview Number Formatting, Messages, and Choices in any language currently in the project.  Not sure how it works yet, we’ll get back to you on that.

Number Formats

[Will be filled in after spec is updated.]

Messages

[Will be filled in after spec is updated.]

Choices

[Will be filled in after spec is updated.]

Setting Preferences

There are a few options that can be set in RBEdit.  The preferences dialogue box allows you to set these options.

To display the Preferences dialogue:

· Select Preferences from the ‘Tools’ menu

[Picture of the Preferences dialogue]

Here are what the various options mean:

[Will be filled in after spec is updated.]

Working with the Windows

QuartzWare RBEdit has as standard an interface as possible.  Merely clicking on the ‘X’ in the upper right hand corner can close editor Windows.  They may also be minimized and maximized as normal.

The ‘Windows’ menu also adds these fairly standard features:

· Cascade Windows – Cascades all of the open windows that are not minimized with the window currently in focus on top

· Tile Horizontally – Uses all of the application space to tile all of the open windows that are not minimized on top of each other with the window currently in focus on top.

· Tile Vertically – Uses all of the application space to tile all of the open windows not minimized next to each other with the window currently in focus on the left.

QuartzWare RBEdit also has one other windows feature that is not quite so standard but can be very useful.  See ‘The ’ on page 10.

Getting Help

There is online documentation available in the program.  

To access the online documentation:

· Select Help Topics from the ‘Help’ menu
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First working draft of the manual.  Chris and Ben created the outline together (all of the headings and subheadings).  Chris wrote everything in the Using the Application Window section plus Testing in Miscellaneous Features.  Ben wrote everything else.
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Ben made changes to the manual to reflect yesterday’s changes to the GUI:

· Changed Tree Window to Project Window

· Updated Project Window to talk about collapsible branches and minimizing, but not closing.

· Renamed File Bar to Easy Tabs and elaborated a little in the Easy Tabs section.

· Renamed all instances of Resource Bundle Editor to RBEdit

· Added some notes about restrictions on Loose Files in the Application Window section

· Gave ‘Renaming a Key’ it’s own section

· Bolded all sentences of the form “To do such and such”

· Put single quotes around menu names and items to click on such as buttons

· Updated ‘Add Child’ description

· Added spec that root may not be removed.

· Removed ‘New(Project’ and ‘New(Child’ from File menu.  There is now just a ‘New Project’ on the File menu

· Clarified a little in Starting from Scratch

· Added ‘Adding a New Child into Project’ section

· Added the graying of values in children different from parent
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