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Overview

In today’s world of global commerce it is increasingly important to get a product out to as many people as possible.  Limiting a product to just one language can severely limit the potential market for it.  This is true even in the computer industry.  While lots of people who work with computers are competent with English, users are much more likely to be comfortable with a program that is in their own language.  

Java helps fix this problem by introducing the idea of internationalization.  Internationalization uses resource bundles as an easy way for your users to switch your software from one language to the next.  A program detects which location, or “locale”, the user has set in their system settings and then loads the appropriate resource bundle that contains the proper strings and other types of data appropriate for that region.  Unfortunately, creating and editing these huge resource bundles can be a huge problem, especially to a translator who has minimal programming skills.  That’s where this program comes in.

QuartzWare RBEdit, the Java Resource Bundle Editor, makes creating and editing resource bundles simple by providing a simple user interface and creating the resource bundles for the user.  It can manage all of the resource bundles together in one project so that a translator never has to actually look at a resource bundle.  This means less time required for training translators, and also makes the job of anyone, including the programmer, who has to work with Java resource bundles a lot easier.

What is a Resource Bundle?

A Resource Bundle is a collection of strings (words and phrases) and other data (such as pictures, messages and arrays) that is to be used in a given program.  The resource bundle contains keys that the program uses to look up these strings and other data to display the program correctly to the end user.  Resource bundles can be divided into two types:

1. Root – This is the file that has every key and is used as the default if a child does not have a
particular key when the program makes an inquiry.  Every key has a particular data type (such as a string or a picture) associated with it, and of course some data.  There is only one Root per project, and the base name for the root is the base name for the project (i.e. if the root is named “BaseName.class” the project is named “BaseName.RBP”.

2. Child – A file that contains a translation of the data in the root for a different language.  Also, other data, such as pictures, may be different from the root.  A child has the same base name as the root but will also have extensions based on it’s categorization.  The nameing convention looks like “BaseName_ln_CT_Var.class”.   See below for details.

· Language (ln) – This category is defined in the ISO-639 standard and contains all the translated strings and data.  The parent of a Resource Bundle with only a language extension is always the root

· Country (CT)  – This category is defined in the ISO-3166 standard and contains any deviations that a language might have from country to country.  Also, formatting, such as dates and time, and pictures, such as that of the countries national flag may be different from country to country.  The parent of a Resource Bundle with a language and a country extension  is always the Resource Bundle with that same language extension.  Note: to specify a country, you must also specify the language.

· Variant (Var) – If there are variations of a language inside of a country, these variations will be found in this file.  The parent of a Resource Bundle with a language, country and a variant extension is always the Resource Bundle with the same language and country extensions.  Note: to specify a variant, you must also specify the language and country.

Please see the ISO-639 and ISO-3166 standards for further information on the naming conventions.  

The children Resource Bundles only contain the data that is different from their parents’ data.  Once the root has been translated into the correct language, all a program has to do is figure out which country it’s in and make a call to the corresponding Resource Bundle.  

The idea behind a Resource Bundle is that the program will request data from a Resource Bundle using a key.  If that key does not exist in that specific Resource Bundle then the program will look at the Resource Bundle’s parent for the data.  This way, a child Resource Bundle only needs to save data that is different from its parent’s data.

Managing Files

In this section, we will talk about what files are involved in a resource bundle project, and how QuartzWare RBEdit manages these files.

A Project vs. a Loose File

The idea behind resource bundles is that there is one file for every language and variation on a language.  A project is a collection of all the files that make up the resource bundles for one particular program.  A project file is created which contains a list of all of the other files in the project, as well as any preferences for that project.  This way, when you load a project, the program automatically loads all of the other resource bundle files in.  A project file has the same name as the root of the Resource Bundle, but it has an extension of ‘RBP’.

Sometimes an entire project is not available and you may wish to work with an individual Resource Bundle.  This is what is known as a loose file, since it isn’t attached with the project currently loaded.  While loose files can be edited in QuartzWare RBEdit, severe restrictions on editing will be in place.  For instance, you will not be able to add a new key or delete a key from a loose file unless it is itself a root.  This is so any child Resource Bundles will not become out of sync with their parents.

[Create a diagram to demonstrate differences between a Project and a Loose file]

Starting a New Project

Starting from Scratch

To create a completely new project, you need to start the project from scratch.

To start a new project from scratch:

1. Select ‘New Project…’ from the ‘File’ menu

2. Click on ‘Create New Root’

3. Name your Project File whatever you wish.

4. Click ‘Save’ to create the Project File and the Root

[Picture of New Project dialogue box]

[Picture of Create New Root dialogue box]

The name you give the Project File will be used as the base name for all of the Resource Bundle Files including the root.

Starting from an existing root

If you have already started the project outside of RBEdit, but would like to continue the project in RBEdit, you need to start a project and import your existing root.

To start a new project based off of existing files:

1. Select ‘New Project…’ from the ‘File’ menu

2. Click on ‘Import Root’

3. Find the Root you wish to import and click on ‘Import’

4. A Save Project dialogue will appear.  Name the project what you wish to and click ‘Save’

5. Load any previously created Children files that go with that Root (See ‘Loading an existing Child into the Project’ on page 8)

[Picture of Import Root dialogue]

If there is a Project already loaded, then a dialogue box will pop up asking if you wish to save.  The base name of the root that you import will be used as the default name in the Save Project dialogue.  Whatever name you choose in the Save project dialogue will be used as the base name for the Project File and all of the children that you load or create.

Loading Files 

Loading an existing Project

To load an existing Project:

[Picture of Open Project Dialogue]

1. Select ‘Open Project’ from the’ File’ menu

2. Find the Project File for the Project that you wish to load. (Remember that Project files have the extension RBP)

3. Click Open to load it into the Resource Editor

If there is a Project already loaded, then a dialogue box will pop up asking you if you wish to save.  The program will automatically load all the Resource Bundles listed in the Project that you load.  If any are missing, a warning message will pop up, asking if you still wish to continue.

If the root or any children are missing then there are some restrictions placed on the Project:

· No Keys may be added or deleted

· The parent value may not be displayed correctly in a child if a parent is missing (an error message will be displayed instead)

· New Resource Bundles may not be added to the Project

· The files that are missing will be grayed out in the Project Window.  You will not be able to open them.

This is done to keep the Children and the Root from becoming out of sync with each other.  For instance, if you added a key to the child, the root would not get that key, and they would become out of sync.

Loading a Loose File

See ‘A Project vs. a Loose File’ on page 3 for a description of a Loose File.

To load a Loose File:

[Picture of Open dialogue box]

1. Select ‘Open’ from the ‘File’ menu

2. Find the Loose File that you wish to load

3. Click Open to load it

4. If a project is already loaded, the Resource Editor will ask if you wish to add this to the current project.  Click no.

Keys may not be removed or added to a Loose File.  The Parent column in the editor window will not be displayed.

Saving Files

Saving the project

To save your project:

· Make sure that a file in the Project (not a Loose file) is in focus.  If not, you will not be able to select ‘Save Project’.  Click on the Project Window or any Editor Window of a Child in the Project.

· Select ‘Save Project’ from the ‘File’ menu

If a Loose File editor window has focus, Save Project will be disabled.  To prevent the children from going out of sync with the root, you are not allowed to individually save the children of a loaded project

Saving the project as a different name

To save your project using a different base name:

[Picture of Save Project As dialogue box]

1. Select ‘Save Project As…’ from the ‘File’ menu

2. Type in a new name for the Project

3. Click Save

The Project File and all of the Resource Bundle Files will be saved using the new name for the Project as the base name.  The previously saved version of all of the Resource Bundles, including the Project File, will remain unchanged.  If this process will cause any files to be overwritten, a warning message will appear first.  The only time this might happen is if you have two projects in the same directory and you try to save the first using the name of the second.

Saving a loose file

See ‘A Project vs. a Loose File’ on page 3 for a description of a Loose File.

To save a Loose File:

1. Make sure that the Loose File you wish to save is in focus (click on it’s editor window to put it in focus)

2. Select ‘Save’ from the ‘File’ menu

If a file in the currently loaded Project has focus, then Save will be disabled.

Working with the files of a Project

Adding a new Child into the Project

To create a new Child for the Project:

1. Select ‘New Child’ from the ‘Project menu

2. Select the language that the child needs to be and click ‘OK’

[Picture of Create New Child dialogue box]

The new child will automatically use the base name of the Project File with the appropriate language extensions the next time the Project is saved.  If a child has a key that the root does not then a dialogue box will pop up with the following options:

· Add Key to Root

· Delete Key from child

· Cancel Loading

Loading an existing Child into the Project

To add an existing Child to the Project:

1. Select ‘Add Child’ from the ‘Project’ menu

2. Find the existing file for the Resource Bundle you wish to add and click ‘Add’

3. Select the language and, if desired, the country and variant that the child is in and click ‘Add’ (Note: if the Resource Bundle was properly named, then the default that comes up should be the right language)

[Picture of the Add Child dialogue box]

The new child will automatically use the base name of the Project File with the appropriate language extensions the next time the Project is saved.  If a child has a key that the root does not then a dialogue box will pop up with the following options:

· Add Key to Root

· Delete Key from child

· Cancel Loading

Removing a child from the Project

To remove a Child from the Project:

1. Select the child in the Project Window that needs to be removed from the Project

2. Select ‘Remove Child’ from the ‘Project’ menu

3. A warning message will pop up.  Click Yes

[Picture of the Project Tree]

Warning!  Removing a child will also remove all of its children.  For example, removing “ResourceBundle_en” will also remove “ResourceBundle_en_US”.  The files are not deleted, but they are removed from the project.  Any changes made to them since the last time the project was saved will be lost.  You may not remove the Root.

Closing Files

Closing a Project

To close a Project:

1. Make sure that any file in a project has focus

2. Select ‘Close’ from the ‘File’ menu

A message will pop up asking if you really wish to save the Project.  Click ‘Yes’ to save it.

Closing a Loose File

See ‘A Project vs. a Loose File’ on page 5 for a description of a Loose File.

To close a Loose File:

1. Make sure that the Loose file you wish to close has focus

2. Select ‘Close’ from the ‘File’ menu

A message will pop up asking if you wish to save the Loose File.

Using the Application Window

The Toolbar

The Toolbar contains shortcuts to various functions that our program supports.  The functions supported are illustrated in the following picture:

[Picture of toolbar with annotations]

The Project Window

The Project Window contains a listing of the files in your project in a tree format.  Each icon in the Project Window represents one Resource Bundle file.  Children are stored on a branch below their parents, and of course the Root is at the top.  Double click on a file to display it in an Editor Window.  Right click in the Project Window to bring up a Pop-Up menu.  To collapse a branch, single click on the ‘-‘ next to it.  To expand a collapsed branch, single click on the ‘+’ sign next to it.

[Picture of Pop-Up menu with annotations]

[Need to specify features of the Pop-Up menu]

You may not close the Project Window, but you may minimize it.  The Project Window is always accessible from the Easy Tabs bar.

The Editor Windows

An Editor Window allows  both display and modification of a given resource bundle.  The Editor Window has four columns:  Key, Value, Parent Value, and Comments.  One row in the editor window is called an Entry.  Each entry, therefore, has one Key, one Value, one Parent Value, and one block of comments.

Undoing and Redoing

QuartzWare RBEdit supports one undo and redo function per editor window.  Selecting Undo from the ‘Edit’ menu will change the last value modified to its previous value.  Selecting Redo from the ‘Edit’ menu will change the value back (as if you had never pressed ‘Undo’ in the first place).

Manipulating text

The cut, copy, and paste features are available when editing the value or comment of an entry.  

Working with Entries

In order to add a new key, either:

· Select ‘New Key’ from the ‘Edit’ menu

· Right click on an Editor Window to bring up a Pop-Up menu, then select ‘New Key’

· Click the ‘New Key’ Icon on the Toolbar.  [Show picture of New Key Icon]

A dialogue box will pop up allowing the user to type in the name of the new key and select the data type for the new key.  See ‘The Data Types of a Key’ on page 13.

[Show data type selection box]

If working with a Loose File (See A Project vs. a Loose File on page 5) then you will not be able to add a new key.

In order to delete a key, select an entry in an editor window, then either:

· Select ‘Delete Key’ from the ‘Edit’ menu

· Right click on the selected entry to bring up a Pop-Up menu, then select ‘Delete Key’

· Click the ‘Delete Key’ Icon on the Toolbar.  [Show picture of Delete Key Icon]

When you try to delete a key, a dialogue box will pop up asking if you are sure.  Click ‘Yes’ to delete the key, or ‘Cancel’ to keep the key.  If working with a Loose File, you will not be able to delete a key.  See A Project vs. a Loose File on page 5
In order to modify the name of a Key:

· Select ‘Rename Key’ from the ‘Edit’ menu

· Right click on the selected entry in an Editor Window to bring up a Pop-Up menu, then select ‘Rename Key’

Renaming a Key should be done with great caution.  This feature is included to allow the correction of typos in the name of a Key.  Any time the Key is changed, it will be changed in ALL files, including the root and every child in the project.  A warning message will pop up asking if you are sure you wish to change the Key.  Click ‘Yes’ to confirm the change or ‘Cancel’ to revert it back.

[Picture of Rename Key Dialogue]

In order to modify a value or comment, select an entry in an editor window, then either:

· Select ‘Edit Value’ or ‘Edit Comments’ from the ‘Edit’ menu

· Double click on the Value or Comments field in the Editor Window

· Right click on the selected entry to bring up a Pop-Up menu, then select  ‘Edit Value’ or ‘Edit Comments’

· Click the  ‘Edit Value’ or ‘Edit Comments’ button on the toolbar  [Show a picture of the Edit Value and Edit Comments icons]

Normally, when you edit a value, you will just type in a new value right into the field in the editor window like a spreadsheet program.  However, some Data Types have dialog boxes associated with them to help you edit the value.  If this is the case then editing the value causes that dialog box to pop up.  See ‘The Data Types of a Key’ on page 13 for a complete explanation of data types and their associated dialog boxes.

When the value of a child is changed, the entire row in the Editor Window will become a light gray to indicate that it is different from it’s parent value.  If a child returns to it’s parent value again than the row will turn white again.  The color that the row turns can be selected from the Preferences dialogue.  See page 18.

Remember the restrictions placed on a Project that has missing Resource Bundles or a Loose File.  See ‘Loading Files’ on page 6.

Searching

Selecting ‘Find’ from the ‘Edit’ menu will bring up a Search Dialog.  The Search Dialog has a number of options.  ‘Search All Resource Bundles’ will search through all files in the current project.  If this option is turned off, only the currently active window will be searched.  You may select which columns (Keys, Values, and/or Comments) will be searched in a Resource Bundle.  By default all columns will be searched, but simply de-select ‘Search Keys’, ‘Search Values’, or ‘Search Comments’ if you wish to narrow the scope of the search.

When a word matching the search parameters is found, that word will be highlighted.  The user may make any edits desired by clicking on the window that the word was found in.  If  the word found is not the specific word desired, then click on ‘Find Next’ to get the next match.  Select ‘Search Up’ or ‘Search Down’ to select the direction that ‘Find Next’ will look in.

[Picture of the Search Dialogue]

The Easy Tabs

The Easy Tabs work similar to the Microsoft Windows’ Taskbar, and they are a simple way to keep track of your work.  It contains a Tab for each Editor Window that is open (including the Project Window and Loose Files).  If a tab is selected, the associated window will become the active window.  If the associated window is minimized, it will restore it, as well as place it on top of any windows that might have been covering it up.

[Put in a picture of the Easy Tabs]

The Data Types of a Key

Every key has a specific Data Type associated with it.  This Data Type can be a string, a picture or any of the several other data types explained in this section.  The Data Type of an Entry is set upon the creation of a new key.  See ‘Working with Entries’ on page 10.  This section explains the available Data Types, and how to edit each Data Type.

StringVal

This Data Type is probably the most common data type to use and will be selected by default in the ‘New Key’ dialog box.  This type contains a normal string of text that is valid under Java’s String type.

To Edit a StringVal Type

· Edit normally as described in ‘Working with Entries’ on page 10.
StringArray

This Data Type allows you to store an array of Strings as described above.  The number of entries is set by the Root.  In the Root dialog box you may add or remove entries in the StringArray as well as modify existing values.  When editing a StringArray in a Child, you may only modify existing values, and the Add and Remove buttons will be disabled.

To Add strings to a StringArray Type

1. Open up the Root file in an Editor Window.  You may only add strings to the root.

2. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 10.

3. Click on Add.  This will add a new entry to the bottom of the list and will automatically be editing the new entry.

4. Edit the String much like you would in the normal Editor Window.  Press ‘Enter’ or click outside of the text box to stop editing.

5. You may add as many strings as you wish or perform other actions in the dialog box.

6. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

To Remove strings from a StringArray

1. Open up the Root file in an Editor Window.  You may only remove strings from the root.

2. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 10.

3. Select an entry in the list by single clicking on it.

4. Click ‘Remove’.  A confirmation box will pop up.  Click ‘Yes’ to confirm or ‘No’ to cancel.

5. You may remove as many strings as you wish or perform other actions in the dialog box.

6. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

To Move a String up or Down in the Array

1. Open up the Root file in an Editor Window.  You may only move a String in the root.

2. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 10.

3. Select an entry in the list by single clicking on it.

4. Click the up arrow or the down arrow.  This will swap the selected String with the String immediately above it or below it.

5. You may remove as many strings as you wish or perform other actions in the dialog box.

6. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

Note:  Moving a String in the Root this way also moves all of the Strings in the Children so that none of the translations will get out of sync with each other.  This is similar to  not being able to add or remove a Key from a Loose File.

To Edit a string in a StringArray Type

1. Open up the Root file in an Editor Window.  You may only  remove strings from the root.

2. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 10.

3. Select an Entry and click modify or double-click an entry.  You will be able to edit entry much like you would in a spread sheet or a normal Editor Window.

4. Type in the new text for the String.

5. You may modify as many strings as you wish.

6. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

BinaryPath

This Data Type contains a special string that is a path to a binary file such as a JPEG, MOV, or any other binary data.  For this Data Type to be used effectively, the user should only use one type of file per key (that is, if the root points to a JPEG, all of the other languages should also point to a JPEG).  The programmer must know what kind of data it is, or be able to detect the type of data it is before it can be used.  This information is not stored in the Resource Bundle.

To Edit a BinaryPath Type

1. Bring up the BinaryPath Dialog box by the various methods described in ‘Working with Entries’ on page 10.

2. The BinaryPath Dialog box looks much like the normal Load File Dialog box.  Select the file you wish to point to.

3. If the file does not yet exist, but will in the future, merely type in the path and file name in the File Name box.

4. Click open.  If the file that you selected does not exist, a warning message will pop up.

[Display a BinaryPath dialog Box and maybe the Warning]

Message

The Message Type is the most complicated Data Type provided in RBEdit.  Messages are a concatenation of Strings and other data (called Elements) in a language neutral way.  Messages assemble a String from various fragments of data such as text, dates, numbers, etc.

To Edit a Message Type

1. Enter text, dates, numbers, and choices into the ‘Full Message’ field.  Dates, numbers, and choices are referred to as “Elements” in the succeeding paragraphs.

2. You may click the ‘Test’ button to see an example message using your formatting.

3. Click ‘OK’ to save the message or click ‘Cancel’ to discard changes to the message.

To Add a New Time or Date to the Message

1. Click the ‘New Element’ button.

2. Type ‘{’ at the position in the ‘Full Message’ field where the date should appear.

3. After the ‘{‘, type in the number in the ‘Message Element Number’ drop down menu, followed by a comma.  This number appeared in the ‘Message Element Number’ drop down menu after the ‘New Element’ button was pressed in step 1.

4. Type the word ‘time’ or the word ‘date’ followed by another comma.

5. Type either ‘short’, ‘medium’, ‘long’, or ‘full’ followed by ‘}’ to finish off the date or time element.

To Add a New Number to the Message

1. Click the ‘New Element’ button.

2. Type ‘{’ at the position in the ‘Full Message’ field where the date should appear.

3. After the ‘{‘, type in the number in the ‘Message Element Number’ drop down menu, followed by a comma.  This number appeared in the ‘Message Element Number’ drop down menu after the ‘New Element’ button was pressed in step 1.

4. Type the word ‘number’ followed by another comma.

5. Type either ‘integer’, ‘currency’, or ‘percent’ followed by ‘}’ to finish off the number element.

To Add a New Choice to the Message

1. Make sure ‘Use Choice Format’ is checked.

2. Click the ‘New Element’ button.

3. Next you must set the limits for your choice, as well as the value that goes within each limit.

4. For each limit, enter the upper bound into the "limit bound field", the value into the "Element Value" field, and select either "# Limit Value", "< Limit Value" or "> Limit Value".  If you wish to use another choice instead of a string as the element value, click the 'Edit as Choice' button.  Click the 'New Limit' button to add this limit to the list.

To Remove an Element from the Message

1. Select the element in the 'Message Element Number' drop down menu.

2. Click the 'Remove Element' button.

BinaryValue

This Data Type contains a binary value entered in hex.  This is implemented as an array of bytes of unspecified length.  The best way to use this is to open a binary file into the ‘Edit a Binary Value’ dialog, but you can type in and edit binary data if you wish.  The difference between a BinaryValue type and a BinaryPath type is that BinaryPath  just stores a path that points to a file, while a BinaryValue actually stores the contents of a binary file in your Resource Bundle.  The binary data is displayed in hex in the dialog box.

To Load and Edit a Binary File into the Resource Bundle

1. Bring up the BinaryValue Dialog box by the various methods described in ‘Working with Entries’ on page 10.

2. Click ‘Open Binary File’.  A standard Open dialog appears

3. Select the file you wish to put into the Resource Bundle and click ‘Open’

4. Edit the file if you wish  using the text field as a normal hex editor (not recommended unless you know what you are doing)

5. Click ‘OK’ to put the binary data into the Resource Bundle.

IntValue

This Data Type allows you to store an Integer as defined by Java.

To Edit a StringVal Type

· Edit normally as described in ‘Working with Entries’ on page 10.
ObjectValue

This Data Type allows you to store the information necessary for a program to create an instance of a class on the fly.

To Edit an Object Value

1. Bring up the ObjectValue Dialog box by the various methods described in ‘Working with Entries’ on page 10.

2. Select the class to create the object from on the left side of the dialog.

3. Type the constructor parameters in the field on the right side of the dialog.

4. You may click the ‘Test’ button to see if the constructor parameters are correct.

5. Click ‘OK’ to put the object  into the Resource Bundle.

IntArray

This Data Type works like a cross between IntVal and StringArray.  You will only be able to enter in integers, but other than that, everything works exactly like a StringArray.  Please see StringArray for details of how to edit.

TaggedArray

This Data Type allows you to store an array of Strings or integers with a textual tag corresponding to each index.  The number of entries is set by the Root.  In the Root dialog box you may add or remove entries in the TaggedArray as well as modify existing values.  When editing a TaggedArray in a Child, you may only modify existing values-- the Add and Remove buttons will be disabled.

To Add entries to a TaggedArray Type

1. Open up the Root file in an Editor Window.  New entries can only be added to the root.

3. Bring up the TaggedArray Dialog box by the various methods described in ‘Working with Entries’ on page 10.

4. Click on Add.  This will add a new entry to the bottom of the both lists.

5. Edit the values much like you would in the normal Editor Window.  Press ‘Enter’ or click outside of the text box to stop editing.

6. You may add as many entries as you wish or perform other actions in the dialog box.

7. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

To Remove entries from a TaggedArray

7. Open up the Root file in an Editor Window.  Entries may only be removed from the root bundle.

8. Bring up the TaggedArray Dialog box by the various methods described in ‘Working with Entries’ on page 10.

9. Select an entry in the list by single clicking on it.

10. Click ‘Remove’.  A confirmation box will pop up.  Click ‘Yes’ to confirm or ‘No’ to cancel.

11. You may remove as many entries as you wish or perform other actions in the dialog box.

12. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

To Move a String up or Down in the Array

7. Open up the Root file in an Editor Window.  You may only move a String in the root.

8. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 10.

9. Select an entry in the list by single clicking on it.

10. Click the up arrow or the down arrow.  This will swap the selected String with the String immediately above it or below it.

11. You may remove as many strings as you wish or perform other actions in the dialog box.

12. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

Note:  Moving a String in the Root this way also moves all of the Strings in the Children so that none of the translations will get out of sync with each other.  This is similar to  not being able to add or remove a Key from a Loose File.

To Edit a string in a StringArray Type

7. Open up the Root file in an Editor Window.  You may only  remove strings from the root.

8. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 10.

9. Select an Entry and click modify or double-click an entry.  You will be able to edit entry much like you would in a spread sheet or a normal Editor Window.

10. Type in the new text for the String.

11. You may modify as many strings as you wish.

12. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

Miscellaneous Features

Setting Preferences

There are a few options that can be set in RBEdit.  The preferences dialogue box allows you to set these options.

To display the Preferences dialogue:

1. Select Preferences from the ‘Tools’ menu

[Picture of the Preferences dialogue]

Here are what the various options mean:

[To be completed]

Working with the Windows

QuartzWare made the RBEdit interface as standard as possible.  Merely clicking on the ‘X’ in the upper right hand corner can close editor Windows.  They may also be minimized and maximized as normal.

The ‘Windows’ menu also adds these fairly standard features:

· Cascade Windows – Cascades all of the open windows that are not minimized with the window currently in focus on top

· Tile Horizontally – Uses all of the application space to tile all of the open windows that are not minimized on top of each other with the window currently in focus on top.

· Tile Vertically – Uses all of the application space to tile all of the open windows not minimized next to each other with the window currently in focus on the left.

· Access to every Resource Bundle that is open in an Editor Window

QuartzWare RBEdit also has one other windows feature that is not quite so standard but can be very useful.  See ‘The Easy Tabs’ on page 12.

Getting Help

There is online documentation available in the program.  

To access the online documentation:

1. Select Help Topics from the ‘Help’ menu

Document Version Control:

10/28/00-11/02/00 Ver 1.12a


Ben made the following changes to the document:

· Updated ‘Modify value’ section under ‘Working with Entries’ to conform more with the ‘Data Types of Keys’ section.

· Changed the ‘Add Child’ so that selecting the new language is a separate dialog from the loading dialog

· Wrote the following sections for ‘Data Types of Keys’ section:

· Introduction

· StringVal

· StringArray

· BinaryPath

· BinaryVal

· IntVal

· IntArray

Chris made the following changes to the document

· Wrote the following sections for ‘Data Types of Keys’ section:

· Message

· ObjectVal

· TaggedArray

10/26/00 Ver 1.11a


Ben made the following changes to the document

· A few minor changes throughout the document to clarify questions that John Dalbey had while reading the manual.

· NOTE: UI Search and User Manual Search do not match!!!

10/18/00 Ver 1.10a


Ben made the following changes (FTR Means that it was a suggestion received in our FTR):

· Minor grammatical changes to entire document

· FTR:  Redid the “What is a Resource Bundle” section from the “2. Child” part on.

· FTR:  Replaced all bullets that indicated steps in a process with numbers to distinguish them from a bulleted unordered list 

· FTR:  Put in a note under “A Project vs. a Loose File” that a diagram should be made in order to further explain the difference between a Loose File and a Project.
· Changed ‘project files’ to ‘children files’ under “Starting from an existing root.”
· Updated “Loading an existing project” by specifying what happens when the root or a child is missing
· Updated the restrictions placed on a Loose File
· Added a new section titled “The Data Types of a Key”
· Changed “Working with Entries” to reflect the previous change.
· Removed the “Testing” section from Misc Features since that will now be covered under “The Data Types of a Key”
· FTR:  Fixed Cross Reference problem under “Working with the Windows”
· FTR:  Added comment on “out of sync” in Loading a Project File
10/15/00 Ver 1.02a


Ben made the following changes:

· Some minor grammatical changes to the Overview to make it less ambiguous

· Added a couple of sentences under “To Save Your Project:”

· Redid that intro to the Editor Windows

· Updated searching section to describe how the results of a find will be displayed

10/11/00 Ver 1.01a


Ben made changes to the manual to reflect yesterday’s changes to the GUI:

· Changed Tree Window to Project Window

· Updated Project Window to talk about collapsible branches and minimizing, but not closing.

· Renamed File Bar to Easy Tabs and elaborated a little in the Easy Tabs section.

· Renamed all instances of Resource Bundle Editor to RBEdit

· Added some notes about restrictions on Loose Files in the Application Window section

· Gave ‘Renaming a Key’ it’s own section

· Bolded all sentences of the form “To do such and such”

· Put single quotes around menu names and items to click on such as buttons

· Updated ‘Add Child’ description

· Added spec that root may not be removed.

· Removed ‘New(Project’ and ‘New(Child’ from File menu.  There is now just a ‘New Project’ on the File menu

· Clarified a little in Starting from Scratch

· Added ‘Adding a New Child into Project’ section

· Added the graying of values in children different from parent

10/9/00  Ver 1.0a


First working draft of the manual.  Chris and Ben created the outline together (all of the headings and subheadings).  Chris wrote everything in the Using the Application Window section plus Testing in Miscellaneous Features.  Ben wrote everything else.
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