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Overview

In today’s world of global commerce it is increasingly important to get a product out to as many people as possible.  Limiting a product to just one language can severely limit the potential market for it.  This is true even in the computer industry.  While lots of people who work with computers are competent with English, users are much more likely to be comfortable with a program that is in their own language.  

Java helps fix this problem by introducing the idea of internationalization.  Internationalization uses resource bundles as an easy way for users to switch your software from one language to the next.  A program detects which location, or “locale”, the user has set in their system settings and then loads the appropriate resource bundle that contains the proper strings and other types of data appropriate for that region.  Unfortunately, creating and editing these huge resource bundles can be a huge problem, especially to a translator who has minimal programming skills.  That’s where this program comes in.

QuartzWare RBEdit, the Java Resource Bundle Editor, makes creating and editing resource bundles simple by providing a simple user interface and creating the resource bundles for the user.  It can manage all of the resource bundles together in one project so that a translator never has to actually look at a resource bundle.  This means less time required for training translators, and also makes the job of anyone, including the programmer, who has to work with Java resource bundles a lot easier.

What is a Resource Bundle?

A Resource Bundle is a collection of strings (words and phrases) and other data (such as pictures, messages and arrays) that is to be used in a given program.  The resource bundle contains keys that the program uses to look up these strings and other data to display the program correctly to the end user.  Resource bundles can be divided into two types:

1. Root – This is the file that has every key and is used as the default if a Bundle does not have a
particular key when the program makes an inquiry.  Every key has a particular data type (such as a string or a picture) associated with it, and of course some data.  There is only one Root per project, and the base name for the root is the base name for the project (i.e. if the root is named “BaseName.class” the project is named “BaseName.RBP”.

2. Bundle – A file that contains a translation of the data in the root for a different language.  Also, other data, such as pictures, may be different from the root.  A Bundle has the same base name as the root but will also have extensions based on its categorization.  The naming convention looks like “BaseName_ln_CT_Var.class”.   See below for details.

· Language (ln) – This category is defined in the ISO-639 standard and contains all the translated strings and data.  The parent of a Resource Bundle with only a language extension is always the root

· Country (CT)  – This category is defined in the ISO-3166 standard and contains any deviations that a language might have from country to country.  Also, formatting, such as dates and time, and pictures, such as that of the countries national flag may be different from country to country.  The parent of a Resource Bundle with a language and a country extension is always the Resource Bundle with that same language extension.  Note: to specify a country, you must also specify the language.

· Variant (Var) – If there are variations of a language inside of a country, these variations will be found in this file.  The parent of a Resource Bundle with a language, country and a variant extension is always the Resource Bundle with the same language and country extensions.  Note: to specify a variant, you must also specify the language and country.

Please see the ISO-639 and ISO-3166 standards for further information on the naming conventions.  

The Child Bundles Resource Bundles only contain the data that is different from their parents’ data.  Once the root has been translated into the correct language, all a program has to do is figure out which country it’s in and make a call to the corresponding Resource Bundle.  

The idea behind a Resource Bundle is that the program will request data from a Resource Bundle using a key.  If that key does not exist in that specific Resource Bundle then the program will look at the Resource Bundle’s parent for the data.  This way, a Bundle Resource Bundle only needs to save data that is different from its parent’s data.

Java Limitations of RBEdit

RBEdit works best when using version 1.3 of Java.  You must use at least version 1.2, but some glitches may occure.

Managing Files

In this section, we will talk about what files are involved in a resource bundle project, and how QuartzWare RBEdit manages these files.

A Project vs. a Loose File

The idea behind resource bundles is that there is one file for every language and variation on a language.  A project is a collection of all the files that make up the resource bundles for one particular program.  A project file is created which contains a list of all of the other files in the project, as well as any preferences for that project.  This way, when you load a project, the program automatically loads all of the other resource bundle files in.  A project file has the same name as the root of the Resource Bundle, but it has an extension of ‘RBP’.

Sometimes an entire project is not available and you may wish to work with an individual Resource Bundle.  This is what is known as a loose file, since it isn’t attached with the project currently loaded.  While loose files can be edited in QuartzWare RBEdit, severe restrictions on editing will be in place.  For instance, you will not be able to add a new key or delete a key from a loose file unless it is itself a root.  This is so any Bundle Resource Bundles will not become out of sync with their parents.  (Please refer to ‘Loading an existing Project’ on page 8 for a detailed list of restrictions.)
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In this example, the current Project is named “RB” and the Loose File is named “LooseFile_en_UK”

Notice that the Loose File does not show up in the Project Window

Starting a New Project

A new project can be started in two ways:

· A new Root Resource Bundle must be created.

· A Root Resource Bundle is already present and is brought into the new project.

Below, we further describe these two options.

Starting from Scratch

To create a completely new project, you need to start the project from scratch.

To start a new project from scratch:

1. Select ‘New Project…’ from the ‘File’ menu

2. Click on ‘Create New Root’
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Name your Project File whatever you wish by typing the name in the Project name field.  The Root Resource Bundle will have the same name.
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Select the ‘File Type’ for your Resource Bundles*
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Click ‘Save’ to create the Project File and the Root

[Save As dialog currently in RBEdit is wrong]

The name you give the Project File will be used as the base name for all of the Resource Bundle Files including the root.

*The File Type is not for the Project file itself.  A Project File is always given a “RBP” extension.  The File Type is for all the Resource Bundles that you will be working with.  All of the Resource Bundles in a Project must be of the same type, and only allowing the user to select that type here ensures that.

The Project Window will now pop up in the Main Window with only an empty Root Resource Bundle.
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Note:  When opening a new Project, if there is a Project already loaded, then a dialogue box will pop up asking if you wish to save.  The base name of the root that you import will be used as the default name in the Save Project dialogue.  Whatever name you choose in the Save project dialogue will be used as the base name for the Project File and all of the Child Bundles that you load or create.

Starting with an existing Root

If you have already started the project outside of RBEdit, but would like to continue the project in RBEdit, you need to start a project and import your existing root.

To start a new project based off of existing files:

1. Select ‘New Project…’ from the ‘File’ menu
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Click on ‘Use Existing Root’

3. Find the Root you wish to import and click on ‘OK’
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[We don’t have any file associations for the import root snapshot.]

4. [image: image21.png][ Quartzware RBEdit 0.7a English - 11/27/00 (-[o[x]
He Edt Project View Windows Holp

D= [*%[e (]

5] Project window o [ Loosefile_en_UK o E
Koy Name | _Value _[parents val.| Gommerts
o
Fenur #d B
Fenus #d B
™ Keyiame Vale | ParentsValue | Comments

1/ Binary Fle lidsrbeditiobjectv...A Binary File
0 Binary Num...3002103ffeeddcc 3002103feeddcc A Binary Number

{2 Integer Array 16,233 15233 An integer Array.
o] 2 nteger 3 3 An nteger
s[> Message 1love the smell.. I 1ove the smell... An Message
‘17 object new JFrame("H... new JFrame("H... An Object

L String Wsasting _ Ksasting A Sting

B StringArray  One,Two, Three,... One,Two, Three,... A String Array.

D TaggedArray Double Click to .. Double Click to .. A TaggedArray




A Save Project As dialogue will appear.  Enter your desired name for the project in the Project name field and click ‘Save’

Load any previously created Child Bundles files that go with that Root (refer to ‘
You may type in your own values for the Language, but there is no error checking against known languages.  So feel free to make up your own language, but be careful!

5. Loading an existing Bundle into the Project
’ on page 11).

[Save As dialog currently in RBEdit is wrong]

The Project Window will now pop up in the Main Window with only an empty Root Resource Bundle.
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Note:  When opening a new Project, if there is a Project already loaded, then a dialogue box will pop up asking if you wish to save.  The base name of the root that you import will be used as the default name in the Save Project dialogue.  Whatever name you choose in the Save project dialogue will be used as the base name for the Project File and all of the Child Bundles that you load or create.

Loading Files 

Loading an existing Project

To load an existing Project:

1. Select ‘Open Project’ from the’ File’ menu

2. Find the Project File for the Project that you wish to load. (Remember that Project files have the extension RBP)
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Click Open to load it into the Resource Editor

If there is a Project already loaded, then a dialogue box will pop up asking you if you wish to save.  The program will automatically load all the Resource Bundles listed in the Project that you load.  If any Resource Bundles are missing, a warning message will pop up telling you a file or files are missing and will ask if you wish to continue.

If the Root is missing then the following restrictions are placed on the Project:

· No Keys may be added or deleted or renamed.

· The parent value may not be displayed correctly in a Bundle if a parent is missing (an error message will be displayed instead)

· New Resource Bundles may not be added to the Project

If a Bundle is missing then the following restrictions are placed on the Project:

· The parent value may not be displayed correctly in a Bundle if a parent is missing (an error message will be displayed instead)

· New Resource Bundles may not be added to the Project under the missing Bundle

· The files that are missing will be grayed out in the Project Window.  You will not be able to open them.

This is done to keep the Child Bundles and the Root from becoming out of sync with each other.  For instance, if you added a key to the Bundle when the root was missing, the root would not get that key, and they would become out of sync.

Loading a Loose File

See ‘A Project vs. a Loose File’ on page 3 for a description of a Loose File.

To load a Loose File:

1. Select ‘Open’ from the ‘File’ menu

2. Find the Loose File that you wish to load

3. Click Open to load it
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[Open dialog is not to spec yet an loading files doesn’t exist yet]

*NOTE: The following restrictions are in place on a Loose File:

· Does not show up in the project window (but does show up in the Easy Tabs)

· Cannot add or delete a Key

· Cannot see Parent Value

· Cannot modify Key names

* To be implemented
Saving Files

Saving the Project

To save your project:

1. Click on the Project Window or any Editor Window of a Bundle in the Project to bring it into focus (Don’t have a Loose File in focus)
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Select ‘Save’ from the ‘File’ menu

Saving the Project as a different name

To save your project using a different base name:

1. Click on the Project Window or any Editor Window of a Bundle in the Project to bring it into focus (Don’t have a Loose File in focus)

2. Select ‘Save Project As…’ from the ‘File’ menu

3. Type in a new name for the Project
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If desired, select a new File Type for the Resource Bundles to be saved as

5. [image: image35.png]e el _|

[ audio 5] lceCreamDrder jar =
[ mages [ imaiatisva &
B 2] inemstnizsioniava a
(2 Heloword cass 2 MecdaHeloword cass El
(2 Helowordégpiav [ MedaHelowor ava

3] Heloworldbpple class &) MedicWaorldbpplet himl

(2 Helowordpritavs &l

Fiename:  [MessageBunds paperties Open
Files of ype: [Bl Fies (] E )




Click ‘Save’

[Save Project As dialog is not to spec yet]

The Project File and all of the Resource Bundle Files will be saved using the new name for the Project as the base name.  The previously saved version of all of the Resource Bundles, including the Project File, will remain unchanged.  If this process will cause any files to be overwritten, a warning message will appear first.  The only time this might happen is if you have two projects in the same directory and you try to save the first using the name of the second.

Saving a Loose File

See ‘A Project vs. a Loose File’ on page 3 for a description of a Loose File.

To save a Loose File:

1. Make sure that the Loose File you wish to save is in focus (click on it’s editor window to put it in focus)
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Select ‘Save’ from the ‘File’ menu

[image: image38.png]Anay

Siing_[_Paents Siing sy

£ | Cancel
oo
S 8 ——
e s |
o e
t =
A

5 =





[image: image39.png]Add Key.
Rename Key
Remove Key
Edit Value

Edit Comments



[image: image40.png]Anay

Siing_[_Paert’s Siing Okay




Working with the files of a Project

Adding a new Bundle into the Project

To create a new Bundle for the Project (Must have a project currently open):

1. Select ‘New Bundle’ from the ‘Project menu
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Select the Language, then select a Country and/or Variant if desired.  The Language is required, but the Country and Variant are optional.  If the specified Language/Country/Variant combination already exists, an error message will pop up.
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3. Click ‘OK’ 

The New Bundle will automatically be inserted into the Project Window under the appropriate parent.

The new Bundle will automatically use the base name of the Project File with the appropriate language extensions the next time the Project is saved. 

You may type in your own values for the Language, but there is no error checking against known languages.  So feel free to make up your own language, but be careful!

Loading an existing Bundle into the Project

To add an existing Bundle to the Project:

1. Select ‘Import Bundle’ from the ‘Project’ menu

2. Find the existing file for the Resource Bundle you wish to add and click ‘Open’
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Select the language and, if desired, the country and variant that the Bundle is in and click ‘Open’ (Note: if the Resource Bundle was properly named, then the default that comes up should be the right language.  If not, just select the language like normal)
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As above when adding a New Bundle, adding and Existing Bundle will automatically insert the new Bundle into the Project Window in the appropriate place. The new Bundle’s file is not created until the next time the Project is saved.  If a Bundle has a key that the root does not then a dialogue box will pop up with the following options:

Removing a Bundle From the Project

To remove a Bundle from the Project:

1. Select the Bundle in the Project Window that needs to be removed from the Project

2. Select ‘Remove Bundle’ from the ‘Project’ menu
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A warning message will pop up.  Click Yes
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Warning!  Removing a Bundle will also remove all of its Children.  For example, removing “ResourceBundle_en” will also remove “ResourceBundle_en_US”.  The files are not deleted, but they are removed from the project.  Any changes made to them since the last time the project was saved will be lost.  You may not remove the Root.

Closing Files

Closing a Project

To close a Project:

1. Make sure that any file in a project has focus (See Saving the Project)

2. Select ‘Close’ from the ‘File’ menu
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A message will pop up asking if you wish to save the Project.  Click ‘Yes’ to save it or ‘No’ to discard changes.

Closing a Loose File

See ‘A Project vs. a Loose File’ on page 5 for a description of a Loose File.

To close a Loose File:

1. Make sure that the Loose file you wish to close has focus (See Saving a Loose File)

2. Select ‘Close’ from the ‘File’ menu

A message will pop up asking if you wish to save the Loose File. Click ‘Yes’ to save it or ‘No’ to discard changes.
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Using the Application Window
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The Application Window refers to the main window and all of its parts.  This section basically describes how all of the windows in the program work.  Below is a picture of the Application Window naming all of the parts that are described in this section:
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The Toolbar

The Toolbar contains shortcuts to various functions that our program supports.  The functions supported are explained here:
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Create a new project.  See ‘Starting a New Project’ on page 6.
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Open a project.  See ‘Loading an existing Project’ on page 8.
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Save a project or Loose File.  See ‘Saving Files’ on page 9.
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Cut selected text.  Used when editing a simple data type.
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Copy selected text to the clipboard.  Used when editing a simple data type.
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Paste text from the clipboard.  Used when editing a simple data type.
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Bring up the help dialog.  See ‘Getting Help’ on page 27.
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The Project Window
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The Project Window contains a listing of the files in your project in a tree format.  Each icon in the Project Window represents one Resource Bundle file.  Child Bundles are stored on a branch below their parents, and of course the Root is at the top.  Double click on a file to display it in an Editor Window.  Right click in the Project Window to bring up a Pop-Up menu (displayed below).  To collapse a branch, single click on the ‘Opened Node’ sign next to it.  To expand a collapsed branch, single click on the ‘Closed Node’ sign next to it.

Opened Node




Closed Node

[No popup window coded into project yet]

See ‘Adding a new Bundle into the Project’ and ‘Removing a Bundle from the Project’ for Add Bundle and Remove Bundle.  See ‘Working with Entries’ for Add Key.

NOTE:  You may not close the Project Window, but you may minimize it.  The Project Window is always accessible from the Easy Tabs bar.

The Editor Windows




An Editor Window allows both display and modification of a given resource bundle.  The Editor Window has four columns:  Key, Value, Parent Value, and Comments.  One row in the editor window is called an Entry.  Each entry, therefore, has one Key, one Value, one Parent Value, and one block of comments.   Right clicking brings up the following Pop-Up menu:

Explanations of these functions can be found in the sections following.

Working with Entries 

In order to add a new key, either:

· Select ‘New Key’ from the ‘Edit’ menu

· Right click on an Editor Window to bring up a Pop-Up menu, then select ‘New Key’

· Click the ‘New Key’ Icon on the Toolbar. 

A dialogue box will pop up allowing the user to type in the name of the new key and select the data type for the new key.  See ‘The Data Types of a Key’ on page 20. 

If working with a Loose File (See A Project vs. a Loose File on page 5) then you will not be able to add a new key.

In order to delete a key, select an entry in an editor window, then either:

· Select ‘Delete Key’ from the ‘Edit’ menu

· Right click on the selected entry to bring up a Pop-Up menu, then select ‘Delete Key’

· Click the ‘Delete Key’ Icon on the Toolbar. 

When you try to delete a key, a dialogue box will pop up asking if you are sure.  Click ‘Yes’ to delete the key, or ‘Cancel’ to keep the key.  If working with a Loose File, you will not be able to delete a key.  See A Project vs. a Loose File on page 5

In order to modify the name of a Key, then either:

· Select ‘Rename Key’ from the ‘Edit’ menu

· Right click on the selected entry in an Editor Window to bring up a Pop-Up menu, then select ‘Rename Key’

You will be able to type the new key in like when you are editing a comment.  A warning message will pop up asking if you are sure you wish to change the Key.  Click ‘Yes’ to confirm the Change or ‘No’ to revert it back.


Renaming a Key should be done with great caution.  This feature is included to allow the correction of typos in the name of a Key.  Any time the Key is changed, it will be changed in ALL files, including the root and every Bundle in the project.

In order to modify a value or comment, select an entry in an editor window, then either:

· Select ‘Edit Value’ or ‘Edit Comments’ from the ‘Edit’ menu

· Double click on the Value or Comments field in the Editor Window of the Entry you wish to edit.

· Right click on the selected entry to bring up a Pop-Up menu, then select  ‘Edit Value’ or ‘Edit Comments’

· Click the  ‘Edit Value’ or ‘Edit Comments’ button on the toolbar  

Normally, when you edit a value, you will just type in a new value right into the field in the editor window like a spreadsheet program.  However, some Data Types have dialog boxes associated with them to help you edit the value.  If this is the case then editing the value causes that dialog box to pop up.  See ‘The Data Types of a Key’ on page 20 for a complete explanation of data types and their associated dialog boxes.

As a default, if the Bundle value has not been change from that of its parent value, the parent’s value is displayed in Value and the entry is shown in gray.  This helps facilitate the translation of values that have not yet been translated.  Bundle values that differ from their parent’s values are shown in black to represent that they have been changed.  Option colors can be used in place of black and gray, and the background color may even be set.  See ‘Setting Preferences’ on page 26.

Remember the restrictions placed on a Project that has missing Resource Bundles or a Loose File.  See ‘Loading Files’ on page 8.

Searching

Selecting ‘Find’ from the ‘Edit’ menu will bring up a Find Dialog.  The Find Dialog has a number of options.  ‘Search All Resource Bundles’ will search through all files in the current project.  If this option is turned off, only the currently active window will be searched.  You may select which columns (Keys, Values, and/or Comments) will be searched in a Resource Bundle.  By default all columns will be searched, but simply de-select ‘Search Keys’, ‘Search Values’, or ‘Search Comments’ if you wish to narrow the scope of the search.

When a word matching the search parameters is found, that word will be highlighted in the Editor Window.  The user may make any edits desired by clicking on the window that the word was found in.  If the word found is not the specific word desired, then click on ‘Find Next’ to get the next match.  Select ‘Search Up’ or ‘Search Down’ to select the direction that ‘Find Next’ will look in.

Undoing and Redoing

QuartzWare RBEdit supports one undo and redo function per editor window.  Selecting Undo from the ‘Edit’ menu will change the last value modified to its previous value.  Selecting Redo from the ‘Edit’ menu will change the value back (as if you had never pressed ‘Undo’ in the first place).

Manipulating text

The cut, copy, and paste features are available when editing the value of a Simple Data Type (See ‘The Data Types of a Key’ on page 20) or comment of any type of entry.  

Viewing/Hiding the Fields

From time to time, you may want to only be looking at one or two of the Key, Value, Parent Value, or comments fields instead of all four.  RBEdit makes this easy to do.  Simply right click in the Editor Window and a Pop-up menu will appear.  You can also find it in the ‘View’ menu.  To hide a field that is showing, simply uncheck (by clicking on) the field that you wish to hide.  To show that field again, bring up the menu and check it again.



NOTE:  When working with the Root, the Parent Value field is never displayed.

The Easy Tabs

The Easy Tabs work similar to the Microsoft Windows’ Taskbar, and they are a simple way to keep track of your work.  It contains a Tab for each Editor Window that is open (including the Loose Files) plus the Project Window.  If a tab is selected, the associated window will become the active window.  If the associated window is minimized, it will be restored, as well as placed on top of any windows that might have been covering it up.

Here’s a picture of the main window.  Notice how the active window corresponds to the selected tab.



The Data Types of a Key

Every key has a specific Data Type associated with it.  This Data Type can be a string, a picture or any of the several other data types explained in this section.  The Data Type of an Entry is set upon the creation of a new key.  See ‘Working with Entries’ on page 15.  This section explains the available Data Types, and how to edit each Data Type.  A Simple Data Type refers to a Data Type that does not need it’s own dialog box.  A Complex Data Type refers to a Data Type that requires a dialog box to edit it’s value.  With a Simple Data Type, the value that is displayed in the Editor Window is obvious, but the values displayed for Complex Data Types need a little explanation.  This explanation is found below.

StringVal  

This Data Type is a Simple Data Type and is probably the most common data type to use and will be selected by default in the ‘New Key’ dialog box.  This type contains a normal string of text that is valid under Java’s String type.

To Edit a StringVal Type

· Edit normally as described in ‘Working with Entries’ on page 15.
StringArray  

This is a Complex Data Type that allows you to store an array of Strings as described above.  The number of entries is set by the Root.  In the Root dialog box you may add or remove entries in the StringArray as well as modify existing values.  When editing a StringArray in a Bundle ( with the exception of the root bundle) , you may only modify existing values, and the Add and Remove buttons will be disabled.

The Value that is displayed in the Editor Window is the elements of the array separated by a comma

[Show a picture of an array display]

NOTE:  When editing the root, the parent String List will be empty.

To Add strings to a StringArray Type

1. Open up the Root file in an Editor Window.  You may only add strings to the root.

2. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 15.

3. Click on Add.  This will add a new entry to the bottom of the list and will automatically be editing the new entry.

4. Edit the String much like you would in the normal Editor Window.  Press ‘Enter’ or click outside of the text box to stop editing.

5. You may add as many strings as you wish or perform other actions in the dialog box.

6. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.


To Remove strings from a StringArray

1. Open up the Root file in an Editor Window.  You may only remove strings from the Root.

2. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 15.

3. Select an entry in the list by single clicking on it.

4. Click ‘Remove’.  A confirmation box will pop up.  Click ‘Yes’ to confirm or ‘No’ to cancel.

5. You may remove as many strings as you wish or perform other actions in the dialog box.

6. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

To Move a String Up or Down in the Array

1. Open up the Root file in an Editor Window.  You may only move a String in the Root.

2. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 15.

3. Select an entry in the list by single clicking on it.

4. Click the up arrow or the down arrow.  This will swap the selected String with the String immediately above it or below it.

5. You may move as many strings as you wish or perform other actions in the dialog box.

6. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.

Note:  Moving a String in the Root this way also moves all of the Strings in the Child Bundles so that none of the translations will get out of sync with each other.  This is similar to not being able to add or remove a Key from a Loose File.

To Edit a string in a StringArray Type

1. Open up the Root file in an Editor Window.  You may only remove strings from the root.

2. Bring up the StringArray Dialog box by the various methods described in ‘Working with Entries’ on page 15.

3. Select an Entry and click ‘Modify’ or double-click an entry.  You will be able to edit entry much like you would in a spreadsheet or a normal Editor Window.

4. Type in the new text for the string.

5. You may modify as many strings as you wish.

6. Click ‘OK’ to save the changes to the list or ‘Cancel’ to disregard changes to the list.


BinaryPath  

This is a Complex Data Type that contains a special string that is a path to a binary file such as a JPEG, MOV, or any other binary data.  For this Data Type to be used effectively, the user should only use one type of file per key (that is, if the root points to a JPEG, all of the other languages should also point to a JPEG).  The programmer must know what kind of data it is, or be able to detect the type of data it is before it can be used.  This information is not stored in the Resource Bundle.

The Value displayed in the Editor Window is the Path and Filename of the file that is selected.

To Edit a BinaryPath Type

1. Bring up the BinaryPath Dialog box by the various methods described in ‘Working with Entries’ on page 15.

2. The BinaryPath Dialog box looks much like the normal Load File Dialog box.  Select the file you wish to point to.

3. If the file does not yet exist, but will in the future, merely type in the path and file name in the File Name box.

4. Click ‘Open’.  If the file that you selected does not exist, a warning message will pop up.

Message  

The Message Type is a Complex Data Type and is the most complicated Data Type provided in RBEdit.  Messages are a concatenation of Strings and other data (called Elements) in a language neutral way.  Messages assemble a String from various fragments of data such as text, dates, numbers, etc.

The Value displayed in the Editor Window is the Full Message described below.

To Edit a Message Type

1. Bring up the Message Dialog box by the various methods described in ‘Working with Entries’ on page 15.

2. Enter text, dates, numbers, and choices into the ‘Full Message’ field (see below for specifics).  Dates, numbers, and choices are collectively referred to as “Elements” in the succeeding paragraphs.

3. You may click the ‘Test’ button to see an example message using your formatting.

4. Click ‘OK’ to save the message or click ‘Cancel’ to discard changes to the message



To Add a New Time or Date to the ‘Full Message’ field

1. Click the ‘New Element’ button.

2. Type ‘{’ at the position in the ‘Full Message’ field where the date should appear.

3. After the ‘{‘, type in the number in the ‘Message Element Number’ drop down menu, followed by a comma.  This number appeared in the ‘Message Element Number’ drop down menu after the ‘New Element’ button was pressed in step 1.

4. Type the word ‘time’ or the word ‘date’ followed by another comma.

5. Type either ‘short’, ‘medium’, ‘long’, or ‘full’ followed by ‘}’ to finish off the date or time element.
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To Add a New Number to the ‘Full Message’ field

1. Click the ‘New Element’ button.

2. Type ‘{’ at the position in the ‘Full Message’ field where the date should appear.

3. After the ‘{‘, type in the number in the ‘Message Element Number’ drop down menu, followed by a comma.  This number appeared in the ‘Message Element Number’ drop down menu after the ‘New Element’ button was pressed in step 1.

4. Type the word ‘number’ followed by another comma.

5. Type either ‘integer’, ‘currency’, or ‘percent’ followed by ‘}’ to finish off the number element.
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To Add a New Choice to the ‘Full Message’ field

1. Click the ‘New Element’ button.

2. Check ‘Use Choice Format’.

3. Next, set the limits for your choice, as well as the value that goes within each limit.

4. For each limit, enter the upper bound into the "limit bound field", the value into the "Element Value" field, and select either "# Limit Value", "< Limit Value" or "> Limit Value".  If you wish to use another choice instead of a string as the element value, click the 'Edit as Choice' button.  Click the 'New Limit' button to add this limit to the list.
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To Remove an Element from the Message

1. Select the element in the 'Message Element Number' drop down menu.

2. Click the 'Remove Element' button.

3. Modify the text in the ‘Full Message’ field so that the message still makes sense.  (Remove all of the elements of the number that you just deleted from Full Message)
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BinaryVal  

This is a Simple Data Type that contains a binary value entered in hex.  This is implemented as an array of bytes of unspecified length.

To Load and Edit a Binary File into the Resource Bundle

· Edit normally as described in ‘Working with Entries’ on page 15.
IntVal  

This is a Simple Data Type that allows you to store an Integer as defined by Java.

To Edit a StringVal Type

· Edit normally as described in ‘Working with Entries’ on page 15.
IntArray  

This Complex Data Type works like a cross between IntVal and StringArray.  You will only be able to enter in integers, but other than that, everything works exactly like a StringArray.  Please see StringArray for details of how to edit.

ObjectVal

This is a Simple Data type that allows you to store the instantiation of a Java Object.  In this type the user actually types in the line of code to instantiate a class.  An example is provided in the picture below.

This example is the code to instantiate a new JFrame titled “Help Dialog”.

To Edit an ObjectVal Type

· Edit normally as described in ‘Working with Entries’ on page 15.
TaggedArray

Miscellaneous Features

Setting Preferences

There are a few options that can be set in RBEdit.  The preferences dialogue box allows you to set these options.

To display the Preferences dialogue:

1. Select Preferences from the ‘Project’ menu

Here are what the various options mean:

Unchanged Values/Changed Values:  These options will allow you to select the colors for your changed and unchanged values.  Background refers to the background color of an entry, and foreground refers to the text color of an entry.  RBEdit allows you to have different colors for values that have been change from their parent values to easily locate what still needs to be completed.  ‘Unchanged Values’ are those values which are the same as their parents and have yet to be edited/translated.  ‘Changed Values’ are those that have been translated and changed from their parent.  To change a color, simply click on the box and a color picker will appear.

Write escaped characters:  Some systems cannot display all of the Unicode characters.  This option outputs escaped characters instead of Unicode.  An escaped character is just the two bytes that make up a Unicode character preceded by a ‘\U’.  So it will look like this: ‘\U0032’

List Keys Alphabetically:  Normally the keys are listed in the order that they are created in.  This list the keys alphabetically.

Default Visible Fields:  Whenever a new Editor Window is opened normally all the fields are visible.  If you wish a specific field to not be visible when a new Editor Window is opened then uncheck the appropriate check box.

Working with the Windows

QuartzWare made the RBEdit interface as standard as possible.  Merely clicking on the ‘X’ in the upper right hand corner can close editor Windows.  They may also be minimized and maximized as normal.

The ‘Windows’ menu also adds these fairly standard features:

· Cascade Windows – Cascades all of the open windows that are not minimized with the window currently in focus on top

· Tile Horizontally – Uses all of the application space to tile all of the open windows that are not minimized on top of each other with the window currently in focus on top.

· Tile Vertically – Uses all of the application space to tile all of the open windows not minimized next to each other with the window currently in focus on the left.

· Access to every Resource Bundle that is open in an Editor Window

QuartzWare RBEdit also has one other windows feature that is not quite so standard but can be very useful.  See ‘The Easy Tabs’ on page 19.

Getting Help

There is online documentation available in the program.  

To access the online documentation:

1. Select Help Topics from the ‘Help’ menu
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2. Start New Project with Existing Root jpeg
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5. Import Bundle Menu jpeg

6. Import Bundle Dialog jpeg
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11/30/00 Ver 1.42a


Ben made the following changes to the document:

· Added ObjectVal section
· Added TaggedArray section, but did not fill it in yet.
· Gave the warning about Java 1.3 it’s own Subheading
· Put in warning in ‘Create New Bundle’ that says that if you type in your own locale name, there is no error checking.
· Added icons next to each of the Data Type names.
11/29/00 Ver 1.41a


Ben made the following changes to the document:

· Picked up where I left off at page 15 yesterday.  Did not replace the following pictures:

· Pg. 15  Popup window not created yet

· Pg. 15  ‘Add Key’ dialog not available yet, and it’s list box has not been filled in.

· Stopped at page 16.  A lot of the rest of the pictures are going to take some heavy editing in Photoshop since none of the list boxes are implemented in the UI yet.  Decided that the rest of the pictures can do for now, since they look almost exactly the same as the RBEdit without the Java Look and Feel.  

· I would be happy to continue taking screen shots after 205 for the team when RBEdit is in a state that is easier to manipulate all the data.

11/28/00 Ver 1.4a


Ben made the following changes to the document:

· Added in warning about using lower versions than 1.3 of Java in 'Overview'

· Replaced as many pictures as posible with snapshots of the real working UI.  The following is a list of pictures that have not been replaced due to conditions out of my control.  Notes have been placed next to all of them:

· Pg. 8-10  ‘Save Project’, ‘Open Project’, ‘Open’, ‘Import Root’ are not to spec yet.

· Pg. 11  ‘New Bundle’ needs values coded into it.

· Pg. 14  Popup Window not yet implemented

· Did not do beyond page 14.

· Note that the UI was being worked on while this document was being edited, so that there are some buttons and other such things missing in the earlier pictures. The missing features have no effect on the explanation that accompanies the picture though.

· Added explanation of toolbar in the ‘Application Window’

11/17/00 Ver 1.31a


Susan ran spell check on the document.

11/16/00 Ver 1.30a


Ben and Susan worked together to thoroughly QA the document and found many errors.  Susan started making changes to the document before Ben was finished checking his section of the manual.


Susan made the following changes to the document:

· Small edit in the ‘Overview’

· Added a cross-reference to list of restrictions in ‘A Project vs. a Loose File’

· Added short explanation under ‘Starting a New Project’

· Made some small changes to ‘Starting from Scratch’ and ‘Starting with an existing Root’ instructions

· Changed ‘Starting from an existing Root’ to ‘Starting with an existing Root’

· Copied explanation at the bottom of ‘Starting a new Project’ to in between ‘Starting from an existing Root’ and ‘Starting with an existing Root’

Ben made the following changes to the document:

· In ‘Loading an existing Project’ made separate lists of restrictions on a Project when a Bundle is missing and when a Root is missing

· Added list of restrictions to a ‘Loading a Loose File’

· Made the explanation of ‘Saving the Project’

· Rewrote instructions for ‘Adding a new Bundle into the Project’ to include explanation of Country and Variant.

· In ‘Loading an existing Bundle into the Project’ Clarified what happens in Add Bundle if the Resource Bundle loading in was not properly named.  Also clarified the following explanation.

· In ‘The Project Window’ specified that the picture of the Pop-Up menu was the one described in the proceeding paragraph

· Moved ‘Undoing and Redoing’ and ‘Manipulating text’ into a better location in ‘The Editor Windows’ section.

· Specified that the parent value is not shown in the Root Editor Window in ‘Viewing/Hiding the Fields’

· Changed a spec according to George’s wishes.  An Entry is gray (by default) until it has been changed.

· Changed ‘Search Dialog’ to ‘Find Dialog’ under ‘Searching’

· Defined the difference between Simple Data Types and Complex Data Types

· Explained what value is displayed in the Editor Window for each Complex Data Type

· Specified that when editing a StringArray in the Root, the Parent Value list will be empty

· Changed the BinaryVal back to a Simple Data Type as per George’s request.

· Finally updated the fact that the ‘Preferences’ dialog is in the ‘Project’ menu and not the non-existent ‘Tools’ menu.

11/13/00 Ver 1.22a


Ben made the following changes to the document:

· Added in the rest of the pictures except for Toolbar, and icons for data types

· Added in the ‘Choice’ explanation that Chris wrote a long time ago but never got put into the manual

11/12/00 Ver 1.21a


Ben made the following changes to the document:

· Added in ‘Viewing/Hiding fields’ for the Editor Window
· Added in more pictures.  Just a few more to make and insert.
· Added in preferences explanation (finally!)
11/11/00 Ver 1.20a


Ben made the following changes to the document:

· Spent 5 hours adding all the pictures to this document and making the necessary changes to the text.  There are far too many to list here.

10/28/00-11/02/00 Ver 1.12a


Ben made the following changes to the document:

· Updated ‘Modify value’ section under ‘Working with Entries’ to conform more with the ‘Data Types of Keys’ section.

· Changed the ‘Add Bundle’ so that selecting the new language is a separate dialog from the loading dialog

· Wrote the following sections for ‘Data Types of Keys’ section:

· Introduction

· StringVal

· StringArray

· BinaryPath

· BinaryVal

· IntVal

· IntArray

Chris made the following changes to the document

· Wrote the following sections for ‘Data Types of Keys’ section:

· Message

· ObjectVal

· TaggedArray

10/26/00 Ver 1.11a


Ben made the following changes to the document

· A few minor changes throughout the document to clarify questions that John Dalbey had while reading the manual.

· NOTE: UI Search and User Manual Search do not match!!!

10/18/00 Ver 1.10a


Ben made the following changes (FTR Means that it was a suggestion received in our FTR):

· Minor grammatical changes to entire document

· FTR:  Redid the “What is a Resource Bundle” section from the “2. Bundle” part on.

· FTR:  Replaced all bullets that indicated steps in a process with numbers to distinguish them from a bulleted unordered list 

· FTR:  Put in a note under “A Project vs. a Loose File” that a diagram should be made in order to further explain the difference between a Loose File and a Project.
· Changed ‘project files’ to ‘Child Bundles files’ under “Starting from an existing root.”
· Updated “Loading an existing project” by specifying what happens when the root or a Bundle is missing
· Updated the restrictions placed on a Loose File
· Added a new section titled “The Data Types of a Key”
· Changed “Working with Entries” to reflect the previous change.
· Removed the “Testing” section from Misc. Features since that will now be covered under “The Data Types of a Key”
· FTR:  Fixed Cross Reference problem under “Working with the Windows”
· FTR:  Added comment on “out of sync” in Loading a Project File
10/15/00 Ver 1.02a


Ben made the following changes:

· Some minor grammatical changes to the Overview to make it less ambiguous

· Added a couple of sentences under “To Save Your Project:”

· Redid that intro to the Editor Windows

· Updated searching section to describe how the results of a find will be displayed

10/11/00 Ver 1.01a


Ben made changes to the manual to reflect yesterday’s changes to the GUI:

· Changed Tree Window to Project Window

· Updated Project Window to talk about collapsible branches and minimizing, but not closing.

· Renamed File Bar to Easy Tabs and elaborated a little in the Easy Tabs section.

· Renamed all instances of Resource Bundle Editor to RBEdit

· Added some notes about restrictions on Loose Files in the Application Window section

· Gave ‘Renaming a Key’ it’s own section

· Bolded all sentences of the form “To do such and such”

· Put single quotes around menu names and items to click on such as buttons

· Updated ‘Add Bundle’ description

· Added spec that root may not be removed.

· Removed ‘New(Project’ and ‘New(Bundle’ from File menu.  There is now just a ‘New Project’ on the File menu

· Clarified a little in Starting from Scratch

· Added ‘Adding a New Bundle into Project’ section

· Added the graying of values in Child Bundles different from parent

10/9/00  Ver 1.0a


First working draft of the manual.  Chris and Ben created the outline together (all of the headings and subheadings).  Chris wrote everything in the Using the Application Window section plus Testing in Miscellaneous Features.  Ben wrote everything else.

NOTE:  If a Loose File editor window has focus, Save Project will be disabled.  To prevent the Children Bundle from going out of sync with the root, you are not allowed to individually save the Children Bundle of a loaded project








Editor Windows





Project Window





Loose File





Note how a Resource Bundle that is in the Project has focus





Notice how a Loose File has focus, and is not in the Project Window





Project Window





Editor Windows





Easy Tabs





Toolbar





Root





Language





Country





Variant





Data Type icon





Left to Right:


Add Key


Remove Key


Edit Value


Edit Comments





Key, Value, ParentValue, and comments fields
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NOTE: If a file in the currently loaded Project has focus, then Save will be disabled.








Add Key to Root


Delete Key from Bundle


Cancel Loading
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